Exception of type 'System.ExecutionEngineException' was thrown.

Sep 13, 2009 at 2:29 PM

I've followed every step  that is mentioned in the white paper.

But when I'm running the LaptopJack from Visual Studio 2008, it hit the following error

Exception of type 'System.ExecutionEngineException' was thrown.

 LocationReport report = llProv.GetReport();

//double lat = (double)report.GetValue(
                //    SensorPropertyKeys.SENSOR_DATA_TYPE_LATITUDE_DEGREES);
                //double lon = (double)report.GetValue(
                //    SensorPropertyKeys.SENSOR_DATA_TYPE_LONGITUDE_DEGREES);

 

double lat = (double)report.GetValue( SensorPropertyKeys.SENSOR_DATA_TYPE_LATITUDE_DEGREES);

 double lon = (double)report.GetValue( SensorPropertyKeys.SENSOR_DATA_TYPE_LONGITUDE_DEGREES);

 

I debugged the application and I found the varaible 'report' was null in first line.

I'm in Windows 7 RC and I use Vodafone Mobile broadband modem access the internet.

 

Please help me.

 

Coordinator
Sep 14, 2009 at 2:19 PM

Do you have a GPS device installed and enabled in the Windows Control Panel?

Sep 14, 2009 at 6:12 PM

No,

All I've done is just installing the geocoding driver using device manager. After that I enabled that driver using control panel.

There is no other physically connected device attached to my pc, when I'm running the application.

 

Coordinator
Sep 15, 2009 at 2:48 PM

You mention that you used device manager to install the geocoding driver. Did you run the script that was included with the download?

Sep 15, 2009 at 3:17 PM

I tried to run the script 'install.cmd' at first. But it displayed an error that mentioning 'devcon' tool is not available. Then I installed the devcon tool and tried again. Then the driver has been sucessfully installed and I enabled the driever from control panel applet.

 I couldn't run the Llojak source from visual studio. It displays the previous error. But the thing is I could run the demo binaries of LLojak!...

Then I installed the driver using device manager. But the result was same as above.

I'm in Sri Lanka and I'm not sure about geo IP resolution and location providers for Sri Lanka. 

Thanks in adavance for your reply dangriffin...

 

Coordinator
Sep 16, 2009 at 2:19 PM

Ok - I'm not sure about installing the driver binaries via device manager. I never tested that myself, and it sounds like it's not working.

If/when you build your own binaries, my recommendation would be that you use the script, and be sure that all of the steps it performs are successful.